Back in the (Focus) Ring

I’ve been absent in the photography world for a long while. I need to get back into shape. It’s partly been work and lack of anything that inspires me.

I’ve never been an equipment junkie–I think talent is in the eye and not in the equipment. But, I like to have nice things and lenses can last a long time. So, about 4 years ago, I splurged on 2 new lenses before Jackie and I went to France. These were Pentax’ new DA* f2.8 lenses. One is a 16-50/f2.8 and the other a 50-135/f2.8.

The 16-50 quickly became my favorite lens. Even displacing my trusty old F50/1.7 that I used for 20 years, going back to the film days. The image quality throughout the range was exquisite.

Then problems started. The “silent drive” motor went out and I had to send it back to Pentax for repair. Discussions on various photo forums suggested others were having the same problem. Pentax unofficially acknowledged they knew they had issues. After a month, I had my lens back, working again.

Another year passed and the motor failed again. This time, the lens was out of warranty. Against my better judgment, I paid $250 to have the motor repaired because I really loved the image quality. But, not wanting to eat another expensive lens, I sold the 50-135/2.8.

The repaired motor lasted about 6 months and Pentax wouldn’t honor the repair under warranty. So, I set the camera and the lens to manual and I’ve been using it that way for the last 2 years. And I’ve slowly moved away from carrying my camera. Which is why you haven’t seen any output from me in 2 years other than a few opportunistic shots and phone camera snaps.

We’re heading for Washington DC on Monday. I have a conference in a week and it’s Spring Break for the kids. We’re spending a week in DC with our hotel 1 block from the Smithsonian complex. It’s the opening week of the Cherry Blossom Festival. There’s going to be plenty of reasons to have my good camera and my favorite lens.

I spent some time this morning investigating my problem. It turns out this lens still works with older Pentax cameras in “screw drive” mode. And, since the K10D works with older screw drive lenses, it’s just a matter of making the K10D work with the DA* lens in screw drive mode. I read some posts about using tape to cover the SDM contacts, but that didn’t seem to work.

I found a post that showed where the SDM support wasn’t enabled until firmware revision 1.30, which is what is in my camera. So, some searching with my favorite search engine revealed the 1.20 firmware. Except that Pentax prevents reverse installation of older firmware. I found a post that said the headers of the older firmware could be hex-edited to fool the bootloader to install the older firmware. I also found hacked firmware for my camera. I figured I had nothing to lose, so I tried some attempts at hex-editing and failed. Then I just installed the hacked firmware.

I’m happy to report that my camera now auto-focuses again with my favorite lens. It doesn’t use the silent motor drive, but I don’t care. The screw drive is plenty fast and it’s not that noisy. If it works, I’m happy.

Now, I just need to find a permanent home for my photos again…. But that’s another post for another day.

Comments are closed.